XOOPS Cube日本サイト (タグ: Plugg) http://dev.xoopscube.jp/tag/Plugg 最新公開記事 Pluggのその後って http://dev.xoopscube.jp/forum/6931 今年最後の投稿としまして、Pluggなんかの書き込みなんかを。ひとまず、下記にてご返事なんかもらったりしていますが、Pluggの開発は中止になっちゃんたんでしょうか?http://xoopscube.jp/forum/6719何か情報があればうれしいな・・。 今年最後の投稿としまして、Pluggなんかの書き込みなんかを。

ひとまず、下記にてご返事なんかもらったりしていますが、Pluggの開発は中止になっちゃんたんでしょうか?
http://xoopscube.jp/forum/6719

何か情報があればうれしいな・・。]]>
10key 2011-12-26T00:30+09:00 モジュール開発
Pluggの公開はあるのでしょうか・・? http://dev.xoopscube.jp/forum/6719 どうも!ちょっと気になったので・・。Pluggのサイトへ、アクセスできない状況ですが、現状はいかがでしょうか?もしかして、開発中止になったとか・・。情報ありましたら、教えてください。お願いします。 どうも!

ちょっと気になったので・・。
Pluggのサイトへ、アクセスできない状況ですが、現状はいかがでしょうか?
もしかして、開発中止になったとか・・。

情報ありましたら、教えてください。

お願いします。]]>
10key 2010-05-26T16:46+09:00 その他
管理画面にログインできなくなりました!!(Plugg導入済) http://dev.xoopscube.jp/forum/6707 突然管理画面にログインできなくなりました・・・http://サイトアドレス/user/login?return=1http://サイトアドレス/user/registerなどにアクセスすると500エラーになります。Plugg導入済のため、http://サイトアドレス/user.phpやhttp://サイトアドレス/admin.phpにアクセスしてもhttp://サイトアドレス/user/loginにリダイレクトされてしまいます。Pluggのプラグインのxiggやプロフページなどにはアクセスできます。http://サイトアドレス/xigg/1http://サイトアドレス/user/1Pluggの設定でmod_rewriteを有効にしていました。対応する.htaccessも設置しています。もちろんサーバのmod_rewriteは有効です。.htaccessを削除してもリダイレクトは効いていて404エラーになります。ローカルにログインフォームを作ってもリダイレクトしてダメでした。強制的にログインできる方法はないでしょうか??これまでずっと管理者でログイン状態だったのでこの問題に気がつきませんでした。ブロックが違うのか、ゲスト権限に問題があるのか分かりませんが、困っています・・・よろしくお願いいたします。.htaccessの内容↓-----RewriteEngine onRewriteCond %{REQUEST_FILENAME} !-fRewriteCond %{REQUEST_FILENAME} !-dRewriteRule ^(.+)$ modules/Plugg/index.php?q=/$1 [E=REQUEST_URI:/modules/Plugg/index.php?q=/$1,L,QSA]-----環境↓XOOPS Cube Legacy(JP2.0からアップ)php 5.2.8、MySQL 4系 突然管理画面にログインできなくなりました・・・
http://サイトアドレス/user/login?return=1
http://サイトアドレス/user/register
などにアクセスすると500エラーになります。

Plugg導入済のため、
http://サイトアドレス/user.phpや
http://サイトアドレス/admin.phpに
アクセスしても
http://サイトアドレス/user/login
にリダイレクトされてしまいます。

Pluggのプラグインのxiggや
プロフページなどにはアクセスできます。
http://サイトアドレス/xigg/1
http://サイトアドレス/user/1

Pluggの設定でmod_rewriteを有効にしていました。
対応する.htaccessも設置しています。
もちろんサーバのmod_rewriteは有効です。

.htaccessを削除してもリダイレクトは
効いていて404エラーになります。
ローカルにログインフォームを作っても
リダイレクトしてダメでした。

強制的にログインできる方法はないでしょうか??

これまでずっと管理者でログイン状態だったので
この問題に気がつきませんでした。
ブロックが違うのか、ゲスト権限に問題が
あるのか分かりませんが、困っています・・・

よろしくお願いいたします。

.htaccessの内容↓
-----
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.+)$ modules/Plugg/index.php?q=/$1 [E=REQUEST_URI:/modules/Plugg/index.php?q=/$1,L,QSA]
-----
環境↓
XOOPS Cube Legacy(JP2.0からアップ)
php 5.2.8、MySQL 4系]]>
lemon-s 2010-05-03T02:54+09:00 XCL2.1.7
pluggはどうなったの? http://dev.xoopscube.jp/forum/6679 コア的なモジュールになる予定だったのに・・公式サイトはもうアクセスできないね コア的なモジュールになる予定だったのに・・
公式サイトはもうアクセスできないね]]>
lemon-s 2010-03-19T12:10+09:00 その他
Pluggインストール不良について http://dev.xoopscube.jp/forum/6627 Pluggモジュールのインストールが出来ません。私は、以下の環境で使用しています。<環境> XOOPS Cube Legacy 2.1.7 PHP Version 5.1.6 MySQL 5.0.19 Pluggモジュール 1.03モジュールのインストールを行うと、通常であれば、「○○○が追加されました」等のメッセージが羅列され、モジュールがインストールされると思います。しかし、Pluggモジュールをインストールしますと、何もメッセージが出ず、「Topへ戻る」のみ表示されます。一応、管理メニューページの左側には、「Plugg(Plugg)」と表示されてますが、インストール可能なプラグイン一覧よりプラグインをインストールしようとしても、「プラグイン(プラグイン名)をインストールできませんでした。エラー: Failed inserting plugin data into the database.Table 'xoopscubeのdirname.テーブル接頭語_plugg_system_plugin' doesn't exist」  と表示され、プラグインのインストールが出来ません。プラグインのインストールが出来ないというよりも、そもそも、Pluggモジュールがインストール出来ていない印象です。あと、テーブル接頭語_plugg_system_plugn'というテーブルも出来ていません。Pluggは、必要となるシステム構成がPHP5.2以上となってますので、PHP Version 5.1.6では、マズいのでしょうか?それとも、何か別の原因があるのでしょうか?何か対処法があれば、教えて下さい。よろしくお願いします。 Pluggモジュールのインストールが出来ません。

私は、以下の環境で使用しています。
<環境>
 XOOPS Cube Legacy 2.1.7
 PHP Version 5.1.6
 MySQL 5.0.19
 Pluggモジュール 1.03

モジュールのインストールを行うと、通常であれば、
「○○○が追加されました」等のメッセージが羅列され、
モジュールがインストールされると思います。
しかし、Pluggモジュールをインストールしますと、
何もメッセージが出ず、「Topへ戻る」のみ表示されます。


一応、管理メニューページの左側には、「Plugg(Plugg)」と表示されてますが、
インストール可能なプラグイン一覧よりプラグインをインストールしようとしても、

「プラグイン(プラグイン名)をインストールできませんでした。
エラー: Failed inserting plugin data into the database.
Table 'xoopscubeのdirname.テーブル接頭語_plugg_system_plugin' doesn't exist」
 
 と表示され、プラグインのインストールが出来ません。


プラグインのインストールが出来ないというよりも、
そもそも、Pluggモジュールがインストール出来ていない印象です。
あと、テーブル接頭語_plugg_system_plugn'というテーブルも出来ていません。

Pluggは、必要となるシステム構成がPHP5.2以上となってますので、
PHP Version 5.1.6では、マズいのでしょうか?

それとも、何か別の原因があるのでしょうか?

何か対処法があれば、教えて下さい。
よろしくお願いします。]]>
takayan 2010-01-18T23:12+09:00 質問箱
Pluggのmod_rewriteについて http://dev.xoopscube.jp/forum/6597 Plugg for XOOPS Cube Legacy 1.03 について、リリースのコメントにも同様の質問がありますが解決していないようなのでこちらで質問させていただきます。Pluggの一般設定でmod_rewriteを有効に設定し、その画面に書いてある通り.htaccessを設置しました。xigg等はうまくURL短縮化できましたが、userのプロフィールのタブが全て「.../user/1」のような同じリンクになってしまいます。サーバのmod_rewriteは有効です。.htaccessの書き方でしょうか。よろしくお願いいたします。 Plugg for XOOPS Cube Legacy 1.03 について、
リリースのコメントにも同様の質問がありますが
解決していないようなのでこちらで質問させていただきます。

Pluggの一般設定でmod_rewriteを有効に設定し、
その画面に書いてある通り.htaccessを設置しました。
xigg等はうまくURL短縮化できましたが、
userのプロフィールのタブが全て
「.../user/1」のような同じリンクになってしまいます。

サーバのmod_rewriteは有効です。
.htaccessの書き方でしょうか。
よろしくお願いいたします。]]>
lemon-s 2009-11-22T16:31+09:00 その他Ver.(本文に記述)
Plugg for XOOPS Cube Legacy 1.03 について http://dev.xoopscube.jp/forum/6452 いつもお世話になります。バージョン表記が旧バージョンのままです。引用:$modversion['version'] = 1.02;1.2 も 1.3 も同じですが、プロフィール表示がインストールしてもしなくても同じです。(操作のしかたが間違っているかもしれません)頭がイマイチなので良く解らないのですが、このモジュールは XOOPS Cube をプラットフォームとして Legacy モジュールの代替のような方向なのでしょうか...?それと Plugg では、Altsys は必要ないんですよね。# XCL 2.1 でなぜ Altsys が必要なのかは理解に苦しみます...[実行環境]Apache/2.2.11 (Ubuntu)PHP 5.2.6-3ubuntu4.1MySQL 5.0.75-0ubuntu10.2Firefox 3.0.10XCL 2.1.7altsys-0.7 いつもお世話になります。

バージョン表記が旧バージョンのままです。
引用:

$modversion['version'] = 1.02;


1.2 も 1.3 も同じですが、プロフィール表示がインストールしてもしなくても同じです。
(操作のしかたが間違っているかもしれません)

頭がイマイチなので良く解らないのですが、このモジュールは XOOPS Cube をプラットフォームとして Legacy モジュールの代替のような方向なのでしょうか...?

それと Plugg では、Altsys は必要ないんですよね。
# XCL 2.1 でなぜ Altsys が必要なのかは理解に苦しみます...

[実行環境]
Apache/2.2.11 (Ubuntu)
PHP 5.2.6-3ubuntu4.1
MySQL 5.0.75-0ubuntu10.2
Firefox 3.0.10
XCL 2.1.7
altsys-0.7]]>
gondayu 2009-06-11T22:46+09:00 モジュール開発
Plugg1.02がWAMPで真っ白? http://dev.xoopscube.jp/forum/6448 Plugg1.02をいろいろ試させて頂いています。Linux環境では動作しているのですが、WAMP環境でどうもうまく動きません。管理画面より・Plugg>プラグインまたは・Plugg>ロール割り当て(グループ別)を選択すると画面真っ白状態となり、先に進みません。・Plugg>一般設定で「デバッグメッセージを表示する」設定にするとinfoメッセージに混じって以下のようなメッセージが表示されています。何かお分かりでしたらご教示ください。PHP Warning: Cannot modify header information - headers already sent by (output started at */xoops_trust_path/modules/Plugg/pear/Sabai/Log/Writer/HTML.php:82) in file */html/modules/legacyRender/kernel/Legacy_RenderTarget.class.php on line 25Warning: Cannot modify header information - headers already sent by (output started at */xoops_trust_path/modules/Plugg/pear/Sabai/Log/Writer/HTML.php:82) in file */html/modules/legacyRender/kernel/Legacy_RenderTarget.class.php on line 25モジュール:Plugg1.02コア:XCL2.1.7日本語:EUC,UTF-8とも同じOS:WidowsXP【NGのWAMP環境1】XOOPSERVER5_JP_20081031:Apache/2.0.59, MySQL 5.0.45, PHP/5.2.5【NGのWAMP環境2】XAMPP Windows 1.6.6a:Apache/2.2.8, MySQL 5.0.51a, PHP 5.2.5 Plugg1.02をいろいろ試させて頂いています。
Linux環境では動作しているのですが、WAMP環境でどうもうまく動きません。
管理画面より
・Plugg>プラグイン
または
・Plugg>ロール割り当て(グループ別)
を選択すると画面真っ白状態となり、先に進みません。

・Plugg>一般設定
で「デバッグメッセージを表示する」設定にするとinfoメッセージに混じって以下のようなメッセージが表示されています。
何かお分かりでしたらご教示ください。

PHP Warning: Cannot modify header information - headers already sent by (output started at */xoops_trust_path/modules/Plugg/pear/Sabai/Log/Writer/HTML.php:82) in file */html/modules/legacyRender/kernel/Legacy_RenderTarget.class.php on line 25

Warning: Cannot modify header information - headers already sent by (output started at */xoops_trust_path/modules/Plugg/pear/Sabai/Log/Writer/HTML.php:82) in file */html/modules/legacyRender/kernel/Legacy_RenderTarget.class.php on line 25


モジュール:Plugg1.02
コア:XCL2.1.7
日本語:EUC,UTF-8とも同じ
OS:WidowsXP

【NGのWAMP環境1】
XOOPSERVER5_JP_20081031:Apache/2.0.59, MySQL 5.0.45, PHP/5.2.5

【NGのWAMP環境2】
XAMPP Windows 1.6.6a:Apache/2.2.8, MySQL 5.0.51a, PHP 5.2.5]]>
itv 2009-06-09T00:39+09:00 XCL2.1.7
Plugg のプラグインの作り方について http://dev.xoopscube.jp/forum/6422 いつもお世話になります。ブログ:プラグインの作り方 - 1.プラグインの基本構造 と Plugg に標準添付のプラグインのソースコードを見て HelloWorld を作ってみています。以下の手順で作成してみましたが、プラグインとして認識されない模様です。どこか間違っていると思いますのでご指摘して頂ければ幸いです。よろしくお願い致します。1.HelloWorldディレクトリを作成xoops_trust_path/modules/Plugg/plugins/HelloWorld2. PluginInfo.php を作成<?phpclass Plugg_HelloWorld_PluginInfo extends Plugg_PluginInfo{ public function __construct($library, $path, $application) { parent::__construct($library, $path, $application); $this->_version = '1.0.0'; $this->_summary = $this->_('Hello World!と言う文字列を出力するプラグイン。)'; $this->_nicename = $this->_('HelloWorld!)'; }}3. Plugin.php を作成<?phpclass Plugg_HelloWorld_Plugin extends Plugg_Plugin{}4.Plugg 管理画面のプラグインで確認インストール可能なプラグイン一覧に表示されると思いますが、うまく表示できません。#何度か更新も実行してみましたが表示できません。 いつもお世話になります。

ブログ:プラグインの作り方 - 1.プラグインの基本構造 と Plugg に標準添付のプラグインのソースコードを見て HelloWorld を作ってみています。

以下の手順で作成してみましたが、プラグインとして認識されない模様です。
どこか間違っていると思いますのでご指摘して頂ければ幸いです。

よろしくお願い致します。

1.HelloWorldディレクトリを作成

xoops_trust_path/modules/Plugg/plugins/HelloWorld


2. PluginInfo.php を作成

<?php

class Plugg_HelloWorld_PluginInfo extends Plugg_PluginInfo
{
	public function __construct($library, $path, $application)
	{
		parent::__construct($library, $path, $application);
		$this->_version = '1.0.0';
		$this->_summary = $this->_('Hello World!と言う文字列を出力するプラグイン。)';
		$this->_nicename = $this->_('HelloWorld!)';
	}
}


3. Plugin.php を作成

<?php

class Plugg_HelloWorld_Plugin extends Plugg_Plugin
{
}


4.Plugg 管理画面のプラグインで確認

インストール可能なプラグイン一覧に表示されると思いますが、うまく表示できません。

#何度か更新も実行してみましたが表示できません。]]>
gondayu 2009-05-24T12:32+09:00 モジュール開発
Plugg for XCLのXiggプラグインをフォーラムとして使うには http://dev.xoopscube.jp/forum/6408 このことに関してどこにも書いていなかったのでここに書きます。Plugg for XCLのXiggプラグインはその見た目をフォーラムとして運用することが可能です。この日本サイトのフォーラムがまさにそのようにして運用しています。その方法ですが、プラグイン管理ページにおいて、Xiggプラグインの「操作」欄より「複製」リンクをクリックプラグイン複製フォームを記入します。「複製プラグイン名」はなんでも構いませんが、フォームにも書いてある通り、英数小文字にしてください。ここでは仮に複製プラグイン名を「forum」としてプラグインの複製を行ったとします。XOOPS_TRUST_PATH/modules/Plugg/plugins/Xigg/bbsフォルダをコピーし、先に設定した複製プラグイン名(ここでは「forum」)でXOOPS_TRUST_PATH/modules/Plugg/plugins下に保存します。つまり、XOOPS_TRUST_PATH/modules/Plugg/plugins/Xigg/bbsをXOOPS_TRUST_PATH/modules/Plugg/plugins/forumとしてコピーします。コピーしたフォルダ内の「bbs.css」を「複製プラグイン名.css」へと名前変更します。つまり、forum.cssへと名前変更します。以上で見た目がフォーラムのXiggの出来上がりです。複製したプラグインのページを開いてみると、通常のニュースサイトではなくフォーラムの感じが出ていると思います。次回のリリースではbbs.cssを名前変更しなくても良いようにしたいと思います。 このことに関してどこにも書いていなかったのでここに書きます。

Plugg for XCLのXiggプラグインはその見た目をフォーラムとして運用することが可能です。この日本サイトのフォーラムがまさにそのようにして運用しています。

その方法ですが、

  1. プラグイン管理ページにおいて、Xiggプラグインの「操作」欄より「複製」リンクをクリック
  2. プラグイン複製フォームを記入します。「複製プラグイン名」はなんでも構いませんが、フォームにも書いてある通り、英数小文字にしてください。ここでは仮に複製プラグイン名を「forum」としてプラグインの複製を行ったとします。
  3. XOOPS_TRUST_PATH/modules/Plugg/plugins/Xigg/bbsフォルダをコピーし、先に設定した複製プラグイン名(ここでは「forum」)でXOOPS_TRUST_PATH/modules/Plugg/plugins下に保存します。つまり、XOOPS_TRUST_PATH/modules/Plugg/plugins/Xigg/bbsをXOOPS_TRUST_PATH/modules/Plugg/plugins/forumとしてコピーします。
  4. コピーしたフォルダ内の「bbs.css」を「複製プラグイン名.css」へと名前変更します。つまり、forum.cssへと名前変更します。

以上で見た目がフォーラムのXiggの出来上がりです。複製したプラグインのページを開いてみると、通常のニュースサイトではなくフォーラムの感じが出ていると思います。

次回のリリースではbbs.cssを名前変更しなくても良いようにしたいと思います。

]]>
onokazu 2009-05-16T15:24+09:00 その他
Plugg XOOPS Cubeモジュール版1.00インストール報告 http://dev.xoopscube.jp/forum/6399 Plugg XOOPS Cubeモジュール版1.00リリースお疲れ様です。早速、導入させていただきましたが、モジュールのインストールまではエラーなく進んだのですが、いざ、Pluggへアクセスしようとすると、下記のようなエラーが表示されます。Fatal error: Declaration of Plugg_InitFilter::before() must be compatible with that of Sabai_Application_ControllerFilter::before() in /virtual/xxxxxxxx/xxxxxoops__trust_path/modules/Plugg/pear/Plugg/InitFilter.php on line 80<行った作業>・zip形式をダウンロードし解凍。・解凍したファイルを、xoops_trust_pathとXOOPS_ROOT_PATHに解凍どおりのディレクトリ構成でアップ。※ただし、xoops_trust_pathは、xxxxoops_trust_pathと名前を変えています。・XOOPS_ROOT_PATH/modules/Plugg/mediaおよびXOOPS_TRUST_PATH/modules/Plugg/cacheのパーミッションを777に変更。・XOOPS管理画面で、Pluggモジュールをインストールという流れになっています。念のため、アンインストールの方も行ってみましたが、下記のようなエラーが表示されます。Warning: Smarty error: unable to read resource: &quot;file:module_uninstall_success.html&quot; in file /virtual/xxxxxxxx/public_html/www.xxxxxxx.com/class/smarty/Smarty.class.php on line 1092Warning: Request to non-existent config key &quot;modRewrite&quot; in file /virtual/xxxxxxxx/xxxxxoops_trust_path/modules/Plugg/pear/Sabai/Config.php on line 46ひとまず、モジュールはアンインストールされているようでモジュールのインストールに表示されています。上記のような状況となっています。Ver環境としましては、XOOPS CUBE2.1.7RCを利用しています。サーバー環境は、・利用サーバー:CORESERVER・Apache1.3.37・PHP5.2.5・MYSQL5.1.22となっています。ひとまずご報告とお礼でした。 Plugg XOOPS Cubeモジュール版1.00リリースお疲れ様です。

早速、導入させていただきましたが、モジュールのインストールまではエラーなく進んだのですが、いざ、Pluggへアクセスしようとすると、下記のようなエラーが表示されます。

Fatal error: Declaration of Plugg_InitFilter::before() must be compatible with that of Sabai_Application_ControllerFilter::before() in /virtual/xxxxxxxx/xxxxxoops__trust_path/modules/Plugg/pear/Plugg/InitFilter.php on line 80

<行った作業>

・zip形式をダウンロードし解凍。
・解凍したファイルを、xoops_trust_pathとXOOPS_ROOT_PATHに解凍どおりのディレクトリ構成でアップ。
※ただし、xoops_trust_pathは、xxxxoops_trust_pathと名前を変えています。
・XOOPS_ROOT_PATH/modules/Plugg/mediaおよびXOOPS_TRUST_PATH/modules/Plugg/cacheのパーミッションを777に変更。
・XOOPS管理画面で、Pluggモジュールをインストール

という流れになっています。

念のため、アンインストールの方も行ってみましたが、下記のようなエラーが表示されます。

Warning: Smarty error: unable to read resource: "file:module_uninstall_success.html" in file /virtual/xxxxxxxx/public_html/www.xxxxxxx.com/class/smarty/Smarty.class.php on line 1092

Warning: Request to non-existent config key "modRewrite" in file /virtual/xxxxxxxx/xxxxxoops_trust_path/modules/Plugg/pear/Sabai/Config.php on line 46

ひとまず、モジュールはアンインストールされているようでモジュールのインストールに表示されています。

上記のような状況となっています。

Ver環境としましては、XOOPS CUBE2.1.7RCを利用しています。

サーバー環境は、
・利用サーバー:CORESERVER
・Apache1.3.37
・PHP5.2.5
・MYSQL5.1.22
となっています。

ひとまずご報告とお礼でした。]]>
10key 2009-05-14T00:55+09:00 その他Ver.(本文に記述)