XOOPS Cube日本サイト (タグ: 500エラー) http://dev.xoopscube.jp/tag/500%E3%82%A8%E3%83%A9%E3%83%BC 最新公開記事 ユーザー新規登録時に500エラー。(認証キーの送信、本登録は問題ありません・・・) http://dev.xoopscube.jp/forum/6376 いつも参考にさせていただいております。現在、下記のような環境でサイトを稼動しております。---------------------------------------------------さくらサーバー ビジネスプロ(PHP 5.2.8/MySQL 4.0)コア:hd_1.03RC(サーバー構成)─┬─xoops_trust_path(サイトA用) │ │ ├─サイトB──xoops_trust_path(サイトB用) │ │ └─www─┬─サイトA         │         │         └─サイトB---------------------------------------------------サイトA・サイトBを同じサーバーで管理しています。(データベースは別です)表題の問題が発生し始めたのはサイトAになります。新規登録登録の流れとして、---------------------------------------------------ユーザー登録フォームhttp://********/register.php↓確認画面http://********/register.php?action=confirm↓登録が完了しました。記載されたメールを登録メールアドレス宛に承認キーを送信しました。メールの指示に従い、承認を完了してください。http://********/register.php?action=confirm#---------------------------------------------------と通常はなるかと思いますが、サイトAにて500エラーが表示されるようになってしまいました。ユーザーからの問い合わせによって判明したため、いつからというのが明確ではありません。ただ、ここ2~3週間くらいの間に発生したのではと思います。エラーが表示されるのは、登録確認後、送信ボタンを押した直後です。---------------------------------------------------ユーザー登録フォームhttp://********/register.php↓確認画面http://********/register.php?action=confirm↓ここで送信を押すと500エラー画面(Internal Server Error)に切り替わります。---------------------------------------------------ただ、認証キーは送信されており、認証キーによる本登録も問題なく出来ます。確認画面から登録完了ページへの切り替えの時点でエラーが起きているようです。各xoopsサイトのフォーラムで、似たような500エラーに関するスレをいくつか拝見しましたが、このタイミングでのみ表示されてる点、登録は出来るという点においての症例がなく、いまだ解決に至っておりません。さくらサーバーより、エラーログを送ってもらいました。---------------------------------------------------[Thu Apr 16 12:05:21 2009] [error]malformed header from script. Bad header=/home/********/dead.letter... : /home/********/www/********/register.php---------------------------------------------------register.phpで起きているエラーではないかと思いますが、どのような影響から起きている現象なのかわかりません。ちなみに、サイトBは問題なく動いております。ぜひともお知恵をお借りできれば幸いです。
現在、下記のような環境でサイトを稼動しております。

---------------------------------------------------
さくらサーバー ビジネスプロ
(PHP 5.2.8/MySQL 4.0)

コア:hd_1.03RC


(サーバー構成)

─┬─xoops_trust_path(サイトA用)
 │
 │
 ├─サイトB──xoops_trust_path(サイトB用)
 │
 │
 └─www─┬─サイトA
         │
         │
         └─サイトB

---------------------------------------------------


サイトA・サイトBを同じサーバーで管理しています。
(データベースは別です)


表題の問題が発生し始めたのはサイトAになります。


新規登録登録の流れとして、

---------------------------------------------------
ユーザー登録フォーム
http://********/register.php



確認画面
http://********/register.php?action=confirm



登録が完了しました。
記載されたメールを登録メールアドレス宛に承認キーを送信しました。
メールの指示に従い、承認を完了してください。
http://********/register.php?action=confirm#
---------------------------------------------------

と通常はなるかと思いますが、
サイトAにて500エラーが表示されるようになってしまいました。

ユーザーからの問い合わせによって判明したため、
いつからというのが明確ではありません。
ただ、ここ2~3週間くらいの間に発生したのではと思います。


エラーが表示されるのは、登録確認後、送信ボタンを押した直後です。

---------------------------------------------------
ユーザー登録フォーム
http://********/register.php



確認画面
http://********/register.php?action=confirm



ここで送信を押すと500エラー画面(Internal Server Error)に切り替わります。
---------------------------------------------------

ただ、認証キーは送信されており、
認証キーによる本登録も問題なく出来ます。


確認画面から登録完了ページへの切り替えの時点で
エラーが起きているようです。


各xoopsサイトのフォーラムで、
似たような500エラーに関するスレをいくつか拝見しましたが、
このタイミングでのみ表示されてる点、登録は出来るという点においての症例がなく、
いまだ解決に至っておりません。


さくらサーバーより、エラーログを送ってもらいました。
---------------------------------------------------
[Thu Apr 16 12:05:21 2009] [error]
malformed header from script. Bad header=/home/********/dead.letter... : /home/********/www/********/register.php
---------------------------------------------------

register.phpで起きているエラーではないかと思いますが、
どのような影響から起きている現象なのかわかりません。

ちなみに、サイトBは問題なく動いております。


ぜひともお知恵をお借りできれば幸いです。]]>
ky982339 2009-04-22T10:09+09:00 質問箱
500エラーが出てしまい原因が分かりません。 http://dev.xoopscube.jp/forum/5955 初心者ですが試行錯誤しながらxoopsを使わせていただいています。Zen CartのTOPページに画像を追加し、翌日立ち上げてみたら「500 Internal Server Error内部サーバエラー」と表示されサイトが見れなくなってしまいました。前日画像が掲載されたのを確認した記憶があるので、その後どこかいじったのかもしれませんがどこをいじったのか覚えていません。すみません。Zen Cartファイルをもう一度上書きしてみたのですが、エラーは直りませんでした。使用しているサーバーのよくある質問に「一部のXOOPSがブラウザからページが表示されない問題が報告されております。この対処として.htaccessファイルを作成しphp_value phpa off又はmod_gzip_on Noを記述し設置して下さい。」とあったので「php_value phpa off」と記載した.htaccess.txtファイルをxoopsの最初の部分(ad,cache,class,common,docs等がアップされているところ)にアップロードしてみましたが変化ありませんでした。また、500エラーで検索してみると、CGIを実行しようとして、サーバエラーが発生している可能性があり、「CGI::Carp」を使うとブラウザでエラーメッセージを見ることが出来るそうなのですが、#!/usr/local/bin/perl と記載されている部分は見つからない為利用することができません。こうなったらZen Cartを一度消してしまおうと思い、zoxファイルを消去してみましたが、状況が変わりませんでした。ということはZen Cartが原因ではないのかもしれません。これ以上どのようにしたら良いのか分からず投稿いたしました。どなたかご教授よろしくお願い致します。環境XOOPS 2.0.16a JPサーバー:land.toPHP 5.2.3MySQL 4.0.27
Zen CartのTOPページに画像を追加し、翌日立ち上げてみたら

「500 Internal Server Error
内部サーバエラー」

と表示されサイトが見れなくなってしまいました。
前日画像が掲載されたのを確認した記憶があるので、その後どこかいじったのかもしれませんがどこをいじったのか覚えていません。すみません。

Zen Cartファイルをもう一度上書きしてみたのですが、エラーは直りませんでした。

使用しているサーバーのよくある質問に
「一部のXOOPSがブラウザからページが表示されない問題が報告されております。
この対処として.htaccessファイルを作成し
php_value phpa off
又は
mod_gzip_on No
を記述し設置して下さい。」
とあったので「php_value phpa off」と記載した.htaccess.txtファイルをxoopsの最初の部分(ad,cache,class,common,docs等がアップされているところ)にアップロードしてみましたが変化ありませんでした。

また、500エラーで検索してみると、
CGIを実行しようとして、サーバエラーが発生している可能性があり、「CGI::Carp」を使うと
ブラウザでエラーメッセージを見ることが出来るそうなのですが、
#!/usr/local/bin/perl
と記載されている部分は見つからない為利用することができません。

こうなったらZen Cartを一度消してしまおうと思い、zoxファイルを消去してみましたが、
状況が変わりませんでした。
ということはZen Cartが原因ではないのかもしれません。

これ以上どのようにしたら良いのか分からず投稿いたしました。
どなたかご教授よろしくお願い致します。

環境
XOOPS 2.0.16a JP
サーバー:land.to
PHP 5.2.3
MySQL 4.0.27]]>
yawn 2008-07-09T15:37+09:00 質問箱