ホーム > フォーラム > 質問箱 > FcabixShareを正常にインストールできない

FcabixShareを正常にインストールできない
投稿者: hase1111 | 投稿日時: 2010/3/6 15:30 | 閲覧: 5627回
hase1111

ファイル管理のためのモジュールを探していて、
FcabixShareがとても便利そうでしたので、インストールしてみました。
ですが、色々と工夫してみましたが、いまだに正常に動作させられません。
何かヒントがあれば教えてください。
よろしくお願いいたします。

■環境

 cube 2.1
 Hodaディストリビューション

■実施したこと

英語のインストラクションにしたがって、
モジュールインストール、必要フォルダ等の作成を実施済みです。
モジュールのAdmin画面で、以下表示までは出ています。

Root folder is : OK
parent_folder is : OK
parent_folder permissions are : OK
tools folder is : OK

■問題

いざ、フィイルキャビネットの画面にいくと、
枠は表示されるものの、中の文字が全て変換されていない状態です。
例:_MD_FLEXIGRID_COMMAND_DOWNLOAD

また、ページ下部に、数十個のバグが報告されています。
一部分だけ貼り付けておきます。

Notice [PHP]: Use of undefined constant _MD_FLEXIGRID_EXPLORER_TITLE - assumed '_MD_FLEXIGRID_EXPLORER_TITLE' in file modules/fcabix/index.php line 243
Notice [PHP]: Use of undefined constant _MD_FLEXIGRID_COL_NAME - assumed '_MD_FLEXIGRID_COL_NAME' in file modules/fcabix/index.php line 245
Notice [PHP]: Use of undefined constant _MD_FLEXIGRID_COL_CREATEDAT - assumed '_MD_FLEXIGRID_COL_CREATEDAT' in file modules/fcabix/index.php line 246
タグ:

コメント(3)

Re: FcabixShareを正常にインストールできない 
投稿者: SAK-AXYZ | 投稿日時: 2010/3/6 18:08
SAK-AXYZ

DLしてきてざっっくりと中身を見てみましたが、language/japanese/main.phpで指定している
言語定数と、language/english/main.phpで指定している言語定数が合致してませんね。

そのため、もしもutf-8で組んでいるxoopsサイトの場合、languageディレクトリの中に
ja_utf8ディレクトリが存在しないため、engllishの各言語phpを見に行き、そこで
合致するものがないことから、今回の状況が発生します。

その場合、ja_utf8ディレクトリを作成し、そこにjapaneseディレクトリの中身をごっそり
コピーして、かつ各ファイルをUTF-8に変換してやってサーバにupすることで解決すると思われます。

ただし、これはあくまでもxoopsサイトをUTF-8で組んでいる場合の話で。
もしEUCで組んでて、今回の状況が発生するのであれば、コードのどこかに何かがいますね(´・ω・`)

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top