ホーム > フォーラム > 質問箱 > X2.0.16a JP > Myalbum-Pでの画像表示ができない

Myalbum-Pでの画像表示ができない
投稿者: kumakou | 投稿日時: 2009/8/22 15:20 | 閲覧: 10050回
kumakou

2年位前に、Xoopsの本を買ってサーバを立ち上げています
当時から画像表示がうまくいかなかったのでそのままにしていたのですが
今回、必要にかられて何とかしたいと新しく本を買ったりしてみているの
ですがうまく表示されません
何かヒント等あれば教えてください
環境については、
OS 2.6.11-1.1369_FC4
XOOPS 2.0.16a
Myalbum-Pのバージョン 2.88

うまく表示でないため、今回、アンインストールして再度インストール・再アップ
デートしてみました

その時、インストール・再インストール完了したのですが下記のようなエラーメッセージ
はありました

Warning [Xoops]: Smarty error: unable to read resource: "db:myalbum_header.html" in file class/smarty/Smarty.class.php line 1095
Warning [Xoops]: Smarty error: unable to read resource: "db:myalbum_footer.html" in file class/smarty/Smarty.class.php line 1095



同様なメッセージが12行程度ありました
その後、ブロック管理等の設定をして次のように画像を登録しようとしています

メニューのマイアルバムの配下の投稿を開くとMyAlbum-pの画面が出てくる
ここからカテゴリを選択して画像を追加する


【最近の画像(画像付)】は表示てきるが
画面の一番したに下記のエラーが出ている

Warning [PHP]: getimagesize(/home/www/public_html/info/uploads/thumbs/1.jpg) [function.getimagesize]: failed to open stream: No such file or directory in file modules/myalbum/blocks/myalbum_topnews.php line 59

投稿された画像の承認のメニューをみても何も表示されていないが
FFTPで登録状態をみてみると
/uploads/photosにファイルはあるが
/uploads/thumbsにファイルはない

ということで、どのように登録したらきちんと表示されるのかわからなくなりました
どなかた、設定方法・登録方法等教えていただけませんか
よろしくお願いします。

コメント(7)

Re: Myalbum-Pでの画像表示ができない 
投稿者: itv | 投稿日時: 2009/8/22 17:20
itv

kumakou さん、こんにちは。

すみませんがmyAlbum-P に詳しくないので直接の回答ではありませんが
エラーメッセージで検索して頂くと類似の事例が見つかりますのでご参考まで。

http://www.xugj.org/modules/QandA/index.php?post_id=5316
http://xoopscube.jp/forum/4062

また、類似の機能を持つwebphotoというモジュールもあります。
http://xoopscube.jp/module/30
#20088 | | 返信する |
Re: Myalbum-Pでの画像表示ができない 
投稿者: SAK-AXYZ | 投稿日時: 2009/8/24 14:12 | 親コメント: #20088
SAK-AXYZ

横レスで失礼しますが

引用:
エラーメッセージで検索して頂くと類似の事例が見つかりますのでご参考まで。


今回の問題の根本的な部分は、サムネ画像が作成されていないため
getimagesizeがコケて、Warningになる という点です。
ですので、[類似の事例]として挙げられているものは、実はまったく類似していないと思われます。
Re: Myalbum-Pでの画像表示ができない 
投稿者: itv | 投稿日時: 2009/9/1 23:13 | 親コメント: #20090
itv
引用:
横レスで失礼しますが

引用:
エラーメッセージで検索して頂くと類似の事例が見つかりますのでご参考まで。

今回の問題の根本的な部分は、サムネ画像が作成されていないため
getimagesizeがコケて、Warningになる という点です。
ですので、[類似の事例]として挙げられているものは、実はまったく類似していないと思われます。


随分遅くなってすみません。このレスに気づきませんでした。
無関係な事例を紹介してすみませんでした。
Re: Myalbum-Pでの画像表示ができない 
投稿者: SAK-AXYZ | 投稿日時: 2009/8/24 13:58
SAK-AXYZ

要は、サムネイルが作成されていないということで……
まずは以下の確認をおすすめします。

1)Myalbum-Pの一般設定で、サムネイルまわりの設定を確認

2)Myalbum-Pの一般設定で、画像処理を行わせるパッケージ選択を確認
 ※imagemagicはサーバによってパスがことなるので、ひとまずGDを選んで於いて
  強制GD2モードをonにして試すのが現実的かと。

3)Myalbum-Pの管理画面内にある[動作チェッカー]で、問題が生じていないかどうか確認

また、 Smarty error: unable to read resource: "db:myalbum_'(略) のエラーについては
DBテンプレート内に当該データが見あたらない、ということですので、altsysのテンプレート管理で
各テンプレートがどうなっているか、確認することをおすすめします。

ちなみに、モジュールインストール時にテンプレートがUPできていないと、テンプレートのテーブルに
行が組まれず、あとからモジュールアップデートで改めてテンプレートを組み込もうとしても
[書き換えるべき行がないために反映されない]という現象が発生します。

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top