ホーム > フォーラム > 質問箱 > ユーザー新規登録時に500エラー。(認証キーの送信、本登録は問題ありません・・・)

ユーザー新規登録時に500エラー。(認証キーの送信、本登録は問題ありません・・・)
投稿者: ky982339 | 投稿日時: 2009/4/22 10:09 | 閲覧: 6059回
ky982339
いつも参考にさせていただいております。

現在、下記のような環境でサイトを稼動しております。

---------------------------------------------------
さくらサーバー ビジネスプロ
(PHP 5.2.8/MySQL 4.0)

コア:hd_1.03RC


(サーバー構成)

─┬─xoops_trust_path(サイトA用)
 │
 │
 ├─サイトB──xoops_trust_path(サイトB用)
 │
 │
 └─www─┬─サイトA
         │
         │
         └─サイトB

---------------------------------------------------


サイトA・サイトBを同じサーバーで管理しています。
(データベースは別です)


表題の問題が発生し始めたのはサイトAになります。


新規登録登録の流れとして、

---------------------------------------------------
ユーザー登録フォーム
http://********/register.php



確認画面
http://********/register.php?action=confirm



登録が完了しました。
記載されたメールを登録メールアドレス宛に承認キーを送信しました。
メールの指示に従い、承認を完了してください。
http://********/register.php?action=confirm#
---------------------------------------------------

と通常はなるかと思いますが、
サイトAにて500エラーが表示されるようになってしまいました。

ユーザーからの問い合わせによって判明したため、
いつからというのが明確ではありません。
ただ、ここ2~3週間くらいの間に発生したのではと思います。


エラーが表示されるのは、登録確認後、送信ボタンを押した直後です。

---------------------------------------------------
ユーザー登録フォーム
http://********/register.php



確認画面
http://********/register.php?action=confirm



ここで送信を押すと500エラー画面(Internal Server Error)に切り替わります。
---------------------------------------------------

ただ、認証キーは送信されており、
認証キーによる本登録も問題なく出来ます。


確認画面から登録完了ページへの切り替えの時点で
エラーが起きているようです。


各xoopsサイトのフォーラムで、
似たような500エラーに関するスレをいくつか拝見しましたが、
このタイミングでのみ表示されてる点、登録は出来るという点においての症例がなく、
いまだ解決に至っておりません。


さくらサーバーより、エラーログを送ってもらいました。
---------------------------------------------------
[Thu Apr 16 12:05:21 2009] [error]
malformed header from script. Bad header=/home/********/dead.letter... : /home/********/www/********/register.php
---------------------------------------------------

register.phpで起きているエラーではないかと思いますが、
どのような影響から起きている現象なのかわかりません。

ちなみに、サイトBは問題なく動いております。


ぜひともお知恵をお借りできれば幸いです。

コメント(0)

新しいものから | 古いものから | ネスト表示 | RSS feed

投票(0)

新しいものから | 古いものから | RSS feed
 
To Top