ホーム > フォーラム > 質問箱 > X2.0.16a JP > サーバ環境変更(PHP・MySQL4→5)にともなうモジュール互換性について

サーバ環境変更(PHP・MySQL4→5)にともなうモジュール互換性について
投稿者: noritaka | 投稿日時: 2008/9/9 12:59 | 閲覧: 8536回
noritaka
現在、CentOS4(MySQL4.1.20、PHP4.3.9)環境で、複数サイトを運用しています。Xoopsのバージョンは、概ね2.0.16a JP(旧安定版)です。

理由があって、CentOS5のサーバへ引っ越さざるを得なくなったのですが、MySQL5・PHP5環境は初めてなので、モジュールの互換性が心配です。
(→MySQL4.1のとき色々あったので。。)


いっそのこと、CentOS5に、MySQL4.x、PHP4.x を、入れてしまおうとも思うのですが、当方、サーバ管理スキルは初級レベルで、パッケージの管理は全てyumに頼り切っております。このため、標準以外のバージョンをインストールする方法が、「ソースからコンパインルするしかない」となると二の足を踏まざるを得ません。

そのほか
※ これを機会に、BASEパッケージをXOOPS Cube Legacyにして、互換性も徹底的にチェックする

※ 通常のCentOS5環境(MySQL5・PHP5)に、とりあえず現在のサイトをそのまま移行してみて様子を見る

・・・という選択肢があると思いますが、どの方法が良いでしょうか?

『XOOPSの旧安定版において、MySQL4.1→5.x・PHP4系→5系の移行は問題ない』・・・との、ご報告が一番うれしいですが(笑)

ご教示の程、よろしくお願い申し上げます。

コメント(4)

Re: サーバ環境変更(PHP・MySQL4→5)にともなうモジュール互換性について 
投稿者: kvex | 投稿日時: 2008/9/9 20:50
kvex
モジュール等、なにを使ってるか洗い出さないとわからないですね。
そうかといって、膨大なモジュール群の全てで検証できているかわかりませんし。

ちなみに、私の管理している xoops 2.0.16 サイトのうち、たまたま以下のようなアップグレードを行ったのですが。
PHP4.4.4 -> 5.1.6
MySQL 4.1 -> 5.0
このときは、特に問題ありませんでした。

    投票(0)

    新しいものから | 古いものから | RSS feed
     
    To Top